[lnkForumImage]
Download FREE Software.

Confronta i prezzi di migliaia di prodotti.
News Forum Italiano
 Home | Login | Registrati | Ricerca 


 

Forums >

it.comp.macintosh

inkscape K.O. ?

Daitarn4

26/01/2019 11:54:21

Mi capita da alcuni giorni che tentando di lanciare Inkscape (installato
tempo fa dall'ultimo dmg disponibile, cioè v.0.92.2) esca questo errore
di XQuartz

https://i.postimg.cc/fLmFG7Kx/Screenshot-2019-01-26-at-12...

e di conseguenza non parte nulla.

Qualcuno ha lo stesso problema? Per caso avete mai provato ad
installarlo tramite MacPorts? Nel caso, meglio la versione X11 o Quartz?

Grazie!

7 Risposte

fbrzvnrnd

27/01/2019 08:57:43

0

Il 26/01/19 12:54, Daitarn4 ha scritto:

a me (0.9.1) parte con XQuartz e 10.12.6

> Mi capita da alcuni giorni che tentando di lanciare Inkscape (installato
> tempo fa dall'ultimo dmg disponibile, cioè v.0.92.2) esca questo errore
> di XQuartz
>

Jack

28/01/2019 12:45:47

0

On Saturday, 26 January 2019 12:54:24 UTC+1, Daitarn4 wrote:
> Mi capita da alcuni giorni che tentando di lanciare Inkscape (installato

dopo che hai fatto qualche aggiornamento dell'OS?

> tempo fa dall'ultimo dmg disponibile, cioè v.0.92.2) esca questo errore
> di XQuartz
>
> https://i.postimg.cc/fLmFG7Kx/Screenshot-2019-01-26-at-12...
>
> e di conseguenza non parte nulla.

Prova a reinstallare XQuartz.

Ciao Jack

Daitarn4

29/01/2019 08:10:29

0

Il 28/01/19 13:45, Jack ha scritto:
> On Saturday, 26 January 2019 12:54:24 UTC+1, Daitarn4 wrote:
>> Mi capita da alcuni giorni che tentando di lanciare Inkscape (installato
>
> dopo che hai fatto qualche aggiornamento dell'OS?

no, nessun aggiornamento, l'unica cosa che ho fatto è stato
disinstallare alcuni programmi che avevo e che non mi servivano più,
insomma ho fatto un po' di pulizia delle applicazioni installate, ma
tutte programmini che non avevano nulla a che fare con Inkscape.

> Prova a reinstallare XQuartz.

a questo non avevo pensato, però nel frattempo ho provato ad installarlo
tramite Macports e questo funziona.
Anche se con questo tipo di installazione perdo alcune comodità, per
esempio il fatto che non ho più un'icona tra le app per poter lanciare
Inkscape, quindi devo aprire una finestra del terminale, lanciare
inkscape da lì (cosa che comunque riporta diversi messaggi d'errore) e
soprattutto ho perso la possibilità di poter far partire il programma
cliccando su un file .svg, che ora non so più come associare, come
estensione, ad Inkscape.

Insomma, ora funziona ma è un accrocchio scomodo.

geobaldi

29/01/2019 23:35:49

0

Daitarn4 <Daitarn4@libero.it> wrote:

> Insomma, ora funziona ma è un accrocchio scomodo.

installalo con homebrew

lilith:~ geobaldi$ brew cask info inkscape
inkscape: 0.92.2-1,11269
https://ink...
Not installed
From:
https://github.com/Homebrew/homebrew-cask/blob/master/Casks/i...
==> Name
Inkscape
==> Artifacts
Inkscape.app (App)
/Applications/Inkscape.app/Contents/Resources/bin/inkscape (Binary)

--
Biting's excellent.
It's like kissing, only there's a winner.

Daitarn4

10/02/2019 09:58:35

0

Il 30/01/19 00:35, gomi no sensei ha scritto:
> Daitarn4 <Daitarn4@libero.it> wrote:
>
>> Insomma, ora funziona ma è un accrocchio scomodo.
>
> installalo con homebrew
>
> lilith:~ geobaldi$ brew cask info inkscape

ho questo errore:

Error: undefined method `run' for Hbc::CLI:Class
/usr/local/Homebrew/Library/Homebrew/cmd/cask.rb:8:in `cask'
/usr/local/Homebrew/Library/Homebrew/brew.rb:94:in `<main>'

Daitarn4

10/02/2019 10:57:39

0

Il 10/02/19 10:58, Daitarn4 ha scritto:
> Il 30/01/19 00:35, gomi no sensei ha scritto:
>> Daitarn4 <Daitarn4@libero.it> wrote:
>>
>>> Insomma, ora funziona ma è un accrocchio scomodo.
>>
>> installalo con homebrew
>>
>> lilith:~ geobaldi$ brew cask info inkscape
>
> ho questo errore:
>
> Error: undefined method `run' for Hbc::CLI:Class
> /usr/local/Homebrew/Library/Homebrew/cmd/cask.rb:8:in `cask'
> /usr/local/Homebrew/Library/Homebrew/brew.rb:94:in `<main>'

per fortuna ho risolto reinstallando xquartz e poi inkscape dal dmg e
ora funziona

Daitarn4

10/02/2019 10:59:45

0

Il 29/01/19 09:10, Daitarn4 ha scritto:
> Il 28/01/19 13:45, Jack ha scritto:
>> Prova a reinstallare XQuartz.
>
> a questo non avevo pensato, però nel frattempo ho provato ad installarlo
> tramite Macports e questo funziona.
>
> Insomma, ora funziona ma è un accrocchio scomodo.

per la cronaca, ha funzionato!
tolta la versione di macports, ho reinstallato xquartz e poi il dmg.